Intermittent issues impacting Identity

Incident Report for LiveRamp External

Resolved

Identity is now fully available again. Thank you for your patience.
Posted 3 months ago. Apr 28, 2025 - 12:08 PDT

Investigating

We're having trouble with Identity. Our engineers have been paged and are looking into it. Thanks for your patience and stay tuned for an update.
Posted 3 months ago. Apr 28, 2025 - 11:46 PDT